1wsza partycja na dysku (drugim) straciła formatowanie

0 głosów
wizyt: 226
hej,

może w skrócie rozwinę karkołomne zapytanie:

Komp stacjonarny, Win7 (legal, wszystkie update są). Dokupuję dysk Toshiba 3TB (data produkcji to kwiecień 2014)  i wsadzam go do kieszeni zew. jako USB.  Okazuje się, że Win widzi tylko ~2TB. Wsadzam go więc do kompa, restart - Win widzi 3TB. Tworzę na mim 4 partycje, formatuję (szybkie, NTFS) - wszystko z poziomu Windowsa, f-cja "zarządzaj-magazyn danych". Wszystko jest OK. Więc wsadzam go do kieszeni USB, resetuje całość, Win wszystko widzi jak należy. Kopiuję na ten dysk pliki. Wszystko jest OK. Na koniec po skopiowaniu plików wsadzam dysk do kompa.

Następnego dnia przy włączeniu mam info, że partycja F (1wsza na nowym dysku) NIE JEST SFORMATOWANA. :-o Kolejne G, H... są ok i pliki na nich też są OK. No trudno - trochę plików straciłem, ale nie jakieś super ważne. Sformatowałem tą partycję na nowo i narazie jest OK.

Dziś (dzień później) rano, włączam kompa a tu komunikat (przed załadowaniem Win, czyli taki DOSowy), że partycja I (ostatnia na nowym dysku) nie jest spójna (albo coś w stym stylu) i będzie sprawdzanie. Ciśnienie mi skoczyło, bo na tej partycji miałem już różne ważne pliki. Mielił chyba z 30min, cały czas się przewijały nazyw plików z JPG (chociaż na partycji mam też dokumenty, aplikacje). Łączył jakieś łańcuchy etc.W końcu zakończył, system się uruchomił i tylko na tej partycji co sprawdzał dane pojawił się plik "bootsqm.dat".

Zdjęć mam tysiące - takie domowe z wakcji etc, zbierane latami i nie sposób sprawdzić, czy wszystkie są OK. Wyrywkowo przeglądałem w różnych katalogach, ale nie trafiłem na żadne błędy.

To tyle - Co Wy na to?! :-) A konkretniej:

- co się dzieje z dyskiem (czy go reklamować - to dla mnie ostateczność)

- czy mogę jakoś sprawdzić, czy jakieś pliki (JPG) utraciłem, albo są z błędami?

 

Dzięki za podpowiedzi i sorry za przydługi opis.
30 sierpnia 2014 w Dyski twarde przez użytkownika flower Poziom 4 (1,690)
   

2 odpowiedzi

0 głosów
Dyski wieksze od 2TB nalezy partycjonowac w stylu GPT, a nie MBR. Aby sprawdzic, jaki masz styl partycjonowania, wybierz Menedzera Urzadzen, odnajdz swoj dysk (np. w stacje dyskow) -> WLasciwosci -> zakladka "Woluminy" i kliknij na Wypelnij.

Jesli masz MBR, to mozesz skonwertowac na GPT:

http://www.partition-tool.com/resource/GPT-disk-partition-manager/convert-mbr-disk-to-gpt-disk.htm

ale wszystkie dane i tak pojda sie rabac, wiec tzreba miec backup. Najlepiej wiec zapartycjonowac od nowa w stylu GPT imiec swiety spokoj.

Dodatkowo Toshiba dla swoich dyskow udostepnia narzedzie dla wykorzystania funkcji AdvancedFormat (PAT) -

https://storage.toshiba.eu/cms/en/support_services/advanced_format.html

przejedz nim juz spartycjonowany dysk i bedziesz widzial, czy partycje sa wlasciwie wyrownane.
odpowiedź 30 sierpnia 2014 przez użytkownika jeomax.co.uk Poziom 11 (466,600)
Dzięki za odpowiedź. "Niestety" sprawdziłęm dysk i mam GPT. Ściągnąłem i zainstalowałem PAT i mam info, że wszystkie partycje są "optimally aligned partition"...

Jakieś inne pomysły? Po prostu się obawiam, czy np. jutro, pojutrze kolejna partycja mi nie "wyparuje" :(
Ja mam takie dziwne wrazenie, ze to sie stalo przez podlaczenie dysku poprzez kontroler USB - i ze takie duze dyski (2TB+) lepiej podlaczac jedynie przez SATA. Opieram sie na tej pierwszej partycji, ktora w/g systemu nie zostala zaformatowana - a takie rzeczy dzieja sie, jak np. glupawy kontroler USB nie obslugujacy takich wielkosci, poprzez adresowanie logicznie ma do wykonania zapis w rejonie czwartej partycji, wykraczajacej poza bariere 2TB, a fizycznie - po blednym przeliczeniu zapisuje bezposrednio na pierwszej (jako nadmiar ponad nieobslugiwany limit), potem powstaja bledy w tablicy partycji - a wiec MBR, w strukturze filesystemu. Moze sie myle, bo dysk - jak dysk - lubi sobie czasem pasc, w koncu to i mechanika, i fizyczne warstwy obracajacych sie tlenkow ferromagnetycznych, czy co tam teraz laduja producenci.
Proponowalbym odciac wiec te sugestie i sprawdzic: dysk podlaczywszy poprzez SATA, najpierw przejechac chkdiskiem, a potem - po upewnieniu sie, ze juz jest 0 bledow w raporcie - sprawdzic zwykly raport SMART, na przyklad programwem CrystalDIskInfo. I pouzywac jeszcze dluzej dysk, ale koniecznie podpiety pod SATA - te dzialania powinny dac juz jakis obraz.

P.S. I jak zwykle to bywa, upewnij sie, ze nie masz wirusa.
0 głosów
Update:

na tej ostatniej partycji miałem oprócz zdjęć także trochę filmów z różnym rozszerzeniem - avi, mp4 etc. Wszystkie były w jednym katalogu. I teraz chciałem jeden odtworzyć i ... błąd! "Ten plik nie jest plikiem audio/video", a z innego playera "brak prawidłowego kodeka". I tak wyrywkowo wszystkie filmy z tej partycji. Z innej filmy normalnie "chodzą". Oczywiście w międzyczasie nic nie zmieniałem - kodeki, player etc.

masakra :(
odpowiedź 30 sierpnia 2014 przez użytkownika flower Poziom 4 (1,690)
Wlasnie doswiadczylem podobnego problemu, bo sobie kupilem Toshibe 3TB na wymiane swojego mniejszego RAID-a i chyba mam rozwiazanie.

Pewnie masz starszy chipset, jak P67, czy Z68 - tam oprogramowanie w OROMie jest nieco starawe i nie tak, jak z Z77, czy rodzina 87/97 - jeszcze aktualizowane. Tak sie wlasnie domyslam, ze trzeba uzupelnic intelowe oprogramowanie instalujac najnowszego IntelRST ze strony producenta na *kazda* z uzywanych partycji systemowych:

https://downloadcenter.intel.com/SearchResult.aspx?lang=&ProductID=2101&ProdId=2101

U mnie pomoglo i kopiowane dane na ostatnio partycje przestaly robic syf w systemie i sa spojne.
Mam MOBO Gigabyte Z77-DS3H.
Od tamtej pory dysk włożyłem do kompa jako 2gi (na 1wszy SSD mam system) i wszystko działa OK. Korzystam z obu partycji (tzn. tych niepewnych - pierwszej i ostatniej)... Myślisz, żeby mimo wszystko zainstalować te sterowniki? Teraz już nie mogę pozwolić sobie na utratę danych bo będzie prawdziwy dramat... :-/
Jesli problem rozwiazany, to bylo mowic ;-) W przypadku plyty Z77 nic sie nie powinno dziac na SATA, a winny najprawdopodobniej jest wlasnie glupawy kontroler na USB, ktory nie traktuje GPT 2TB+ serio.
A oprogramowanie IntelRST mozesz spokojnie zainstalowac, nic sie nie stanie - o ile juz nie masz odpowiedniej wersji zainstalowanej, bo producenci plyt glownych umieszczaja apdejty na swoich stronach do pobrania, ale - jak pisalem - w przypadku P67 (czyli mojej) juz sobie na to leja i trzeba recznie doinstalowywac.
Czy problem rozwiązany to sprawa dyskusyjna :-) Ja nic nie zrobiłem poza przerzuceniem dysku z zew. kieszeni USB do kompa. Trochę czasu minęło i na razie wszystko działa dobrze. Ciężko to jednak nazwać świadomym rozwiązaniem :-) Ale dzięki za (p)odpowiedź.
Wlasnie zrobiles - wywaliles dziadowski kontroler USB, ktory nie obsluguje dyskow wiekszych od 2TB :)
P.S. Ten IntelRST nada sie tylko do RAIDow, jesli masz pojedynczy naped, to sie nawet nie zainstaluje. Jestem juz przemeczony i wczesniej o tym nie wspomnialem, bo siedze 3 dzien z kolei non-stop i walcze z tym dziadostwem, co to sie nazywa UEFI, GPT, MBR oraz BIOS :)
...